Documentation du Dr FRAPPE

Ce wiki regroupe les résultats de mes expériences en informatique accumulés au cours de mes recherches sur le net.

Dans la mesure du possible, j’ai cité mes sources ; il en manque certainement… :-)

Utiliser des programmes 32 bits sur Ubuntu 64 bits

1. Pré-requis

Toujours vérifier si une version 64bits existe avant d’utiliser cette méthode (sauf si elle est trop complexe à installer), elle ne fonctionnera que mieux !

D’ailleurs cette méthode n’est pas infaillible !

2. Première étape

À partir d’Ubuntu 14.04, en mettant en œuvre le concept de multi-arch, on peut installer les dépendances 32 bits via une commande à entrer dans le terminal :

  • sudo dpkg --add-architecture i386

3. Autres étapes

3.1. Installation d'un programme 32 bits

Avec apt, précisez l’architecture :

  • sudo apt install paquet:i386

Si le programme est disponible sous forme d’un paquet .deb, installez-le en tapant dans un terminal

  • sudo dpkg -i --force-architecture [le nom du paquet à installer]

Au lieu de taper tout le chemin vers le fichier, glissez le fichier à installer dans le terminal, puis Entrer et s’il n’y a pas de problèmes, vous venez d’installer un programme !

3.2. Désinstallation d'un programme 32 bits

Un paquet installé avec l’option –force-architecture n’apparaîtra pas dans la liste des paquets installés (par exemple dans Synaptic).

Pour le désinstaller, il suffit d’utiliser l’option -r de dpkg avec le nom du paquet, sans sa version

sudo dpkg -r [le nom du paquet à désinstaller]

Si vous avez installé en mode force-architecture un paquet 32 bits sur un système 64 bits, puis que vous trouvez le paquet 64 bits « équivalent » et que vous voulez l’installer, faites-le.

Vous recevrez une erreur dpkg qui dit « cannot be co-installed with ».

Lisez attentivement le message, qui distinguera le nouveau paquet de l’ancien par une sous-étiquette précédée de « deux points » : pour un paquet *, l’ancien (32bits) sera désigné par *:i386, le nouveau par *:amd_64 (ou rien). Tapez dans le terminal :

sudo dpkg -r [le nom du paquet à désinstaller]:i386

(ou autre selon le message d’erreur)

Puis installez le nouveau paquet, via la Logithèque Ubuntu, ou Synaptic, ou apt.

4. Conclusion

5. Problèmes connus

6. Voir aussi


Contributeurs principaux : jamaique.


Navigation

éditer cette page

QR Code
QR Code Utiliser des programmes 32 bits sur Ubuntu 64 bits (generated for current page)