Documentation du Dr FRAPPE

Ce wiki regroupe les résultats de mes expériences en informatique accumulés au cours de mes recherches sur le net.

Dans la mesure du possible, j'ai cité mes sources ; il en manque certainement… :-)

Thunderbird : un client e-mail

Pré-requis

Installation

Configuration

Les dossiers de Thunderbird

Thunderbird utilise :

  • un dossier Dossiers locaux qui contient l’ensemble des dossiers de base et ceux créés pour pour ranger efficacement les courriels
  • et un dossier pour chaque compte de messagerie paramétré

Nous allons modifier les chemins d’accès pour ces 2 types de dossier.

Sous Windows, Thunderbird crée le dossier contenant les courriels dans le profil de l'utilisateur Windows, comme par exemple C:\Users\MonProfile\AppData\Roaming\Thunderbird\Profiles\5y7ynzp0.default\Mail\

Dans ce dossier nous trouvons :

  • Mail\Local Folders pour le dossier dossiers locaux
  • ImapMail\imap.monFAI.fr pour un compte de messagerie configuré

Tout d'abord, installer Thunderbird dans les deux environnements en configurant les mêmes comptes de messagerie.

Configurer Thunderbird sous Windows

Par sécurité, mieux vaut déplacer les dossiers concernant la messagerie sur un disque ou une partition autre que la partition système. Pour cela :

  1. Fermer Thunderbird (si déjà l’application est déjà lancée)
  2. Copier/coller le dossier …\Mail\ (cf. plus haut) sur une autre partition ou un autre disque, si possible ntfs, dans un dossier, par exemple dans d:\Profil thunderbird
  3. Lancer Thunderbird
  4. Ouvrir Outils → Paramètres des comptes
    1. Sélectionner le compte de messagerie
      1. Sélectionner Paramètres serveur
      2. Modifier le Répertoire local (dernier champ en bas de la fenêtre) pour pointer vers le nouveau dossier créé par le copier/coller précédent (jusqu’à pop.monFAI.fr ou son équivalent)
    2. Sélectionner Dossiers locaux
      1. Modifier le Répertoire local (dernier champ de la fenêtre) pour pointer vers le nouveau dossier créé via le copier/coller précédent (jusqu’à Local Folders)
    3. Enregistrer les modifications en cliquant sur le bouton OK
  5. Fermer Thunderbird et le relancer, on retrouve l’ensemble des dossiers et des courriels

Voici un exemple de configuration :

protuts.net_wp-content_uploads_ubuntu-windows-thunderbird-1.jpg

Configurer Thunderbird sous Ubuntu

Sous ubuntu, modifier les mêmes paramètres dans la configuration de Thunderbird en procédant de la même manière.

L’accès aux paramètres des comptes se fait par le menu Edition → Paramètres des comptes.

protuts.net_wp-content_uploads_ubuntu-windows-thunderbird-2.jpg

Partager un même profil sous Windows et sous Ubuntu

  • Lancez
    $ thunderbird -p
    

    et cliquez sur Create Profile :

  • Cliquez sur Next :
  • paramétrez le nouveau profil :
    1. profile name : mettez le nom de l'utilisateur
    2. Cliquez sur le bouton Choose Folder… et sélectionnez le dossier voulu (par exemple /media/donnees/thunderbird)
    3. Cliquez sur le bouton FinishVous revenez à la fenêtre de choix de profil.
  • S'il y a d'autres profils, il faut les effacer
    • Cliquez sur le nom du profil à effacer puis sur le bouton Delete Profile…
    • Dans la fenêtre qui apparaît, cliquez sur le bouton Delete Files
  • Au retour à la fenêtre de choix de profil, cliquez sur le bouton Exit.

Voilà, le tour est joué !

Utilisation

Importer des fichiers dbx dans Thunderbird sous Ubuntu

  1. Ajoutez un compte Outlook.com :
  2. Connectez-vous, donnez votre mot de passe Microsoft :

Gestion des mails en double

Pour que le serveur n'en ajoute pas

  • Menu Édition → Préférences
  • onglet Avancé
  • éditeur de configuration
  • Je prends le risque.
  • Tapez dans le filtre : mail.server.default.dup_action
  • Donnez à la clé mail.server.default.dup_action la valeur (1 est sans doute le bon choix) :
    • 0 = charger les mails en double comme d’habitude
    • 1 = supprimer automatiquement (et directement) les mails en double dès leur réception.
    • 2 = les mails en double à la poubelle
    • 3 = marquer les mails en double comme “Déjà lu”

avec un plugin

Fusionner plusieurs carnets d'adresse abook.mab

  1. Sous thunderbird, ouvrir le carnet d'adresses. Ouvrir le menu Fichier → Nouveau → Carnet d'adresses… :et donnez-lui un nom (par exemple “transfert”).
  2. Localisez le répertoire du profil :
    • Cliquez sur le bouton menu
    • puis sur Aide
    • choisissez Informations de dépannage.
    • Sous la section Paramètres de base de l’application, ligne Répertoire de profil, cliquez sur le bouton Ouvrir le répertoire correspondant.
    • Votre dossier de profil s’ouvre dans l'explorateur de fichiers
  3. Sortez de thunderbird
  4. Dans l'explorateur de fichiers :
    • allez dans le répertoire du profil.
    • Un nouveau fichier abook-1.mab est apparu.
    • Supprimez-le et remplacez-le par le fichier abook.mab à fusionner après l'avoir renommé en abook-1.mab.
  5. De retour dans thunderbird,
    • on trouve deux carnets d'adresses :
    • Il suffit de glisser-déposer les adresses que l'on veut d'un carnet à l'autre.

Il ne reste plus qu'à éliminer les éventuels doublons.

Problèmes et solutions

Procédez comme suit :

La case Retenir le mot de passe est grisée → impossible de la cocher :

Si cette case n’apparaît pas, utilisez l'éditeur de configuration :

  • cliquez sur le menu Édition → Préférences, sélectionnez le panneau Avancé puis sélectionnez l’onglet Général et enfin cliquez sur le bouton Éditeur de configuration
  • La première fois, un message d’avertissement vous rappelle de faire attention :Soyez donc prudent car une fausse manoeuvre peut rendre Thunderbird inutilisable.
    Décochez la case Afficher cet avertissement la prochaine fois si vous ne voulez plus voir l’avertissement, puis cliquez sur le bouton Je prends le risque pour continuer.
  • Dans l'éditeur de configuration, saisissez signon.rememberSignons dans le champ Rechercher :
  • Mettre signon.rememberSignons à true en double-cliquant sur cette ligne (vous pouvez aussi faire un clic droit et sélectionner Inverser
  • Puis redemarrer TB.

TB crée les dossiers nstmp quand on fait une compression. Ils sont censés être temporaires et invisibles dans TB. S'ils apparaissent, c'est que la compression s'est mal passée, (conflit avec une autre application, comme un antivirus, ou google desktop …)

Pour les faire disparaître: - fermer TB - avec l'explorateur, aller dans …\Thunderbird\Profiles\<truc>.default\Mai - faire une recherche sur nstmp, et tout virer - faire une recherche sur *.msf, et tout virer (rien à craindre, ce sont des index qui sont automatiquement reconstruits par TB) - relancer TB

Désinstallation

Voir aussi


Basé sur « Article » par Auteur.