Documentation du Dr FRAPPE

Ce wiki regroupe les résultats de mes expériences en informatique accumulés au cours de mes recherches sur le net.

Dans la mesure du possible, j'ai cité mes sources ; il en manque certainement… :-)


GnuCash

Le logiciel GnuCash est un logiciel de comptabilité sous licence libre (GPL v3), qui permet de suivre ses comptes de façon professionnelle en toute simplicité.

Pré-requis

Tout d'abord, créons un dossier pour bien organiser les comptes. Par exemple, créons sur le bureau un nouveau dossier et nommons-le : Mes-Comptes (Clic droit sur le bureau, → nouveau → Dossier et écrire le nom)

Le nouveau dossier est créé. On peut le déplacer où on veut, par exemple dans les documents personnels.

Installation

Sous Ubuntu

Pour installer ce logiciel, il suffit d'installer le paquet gnucash

Pour la doc : gnucash-docs

Sous Windows

Télécharger le logiciel sur le site officiel de GnuCash : http://www.gnucash.org/fr/

Sélectionner (menu gauche du site, rubrique téléchargement) le fichier exécutable pour Windows.

Une nouvelle fenêtre du site s'ouvre, celle-ci liste les diverses versions disponibles de GnuCash, choisir la version stable avec un clic gauche de la souris sur Download .

Vous voici à présent avec une présentation de toutes les versions stables de GnuCash pour divers systèmes d'exploitation. Pour Windows prenons le .EXE .

La fenêtre de téléchargement va se lancer automatiquement, plus ou moins rapide selon votre connexion. Confirmer l'enregistrement du logiciel GnuCash.

Le téléchargement est en cours ..

Nous avons donc fini le téléchargement de GnuCash , nous pouvons passer à l'installation du logiciel.

Pour lancer l'installation, faire un double clic gauche avec votre souris sur le logiciel GnuCash, téléchargé précédemment.

L'installation est lancée , il ne vous reste plus qu'à suivre les indications de l'assistant, voir ci-dessous étapes par étapes :

Nous avons fini l'installation, un raccourci est apparu sur le bureau :

Lançons-nous sur le paramétrage de GnuCash .

Configuration

<note>Quelques précisions.

Par défaut, GnuCash fait une sauvegarde automatique de vos actions toutes les 5 minutes, mais également des enregistrements des historiques sont conservés pendant 30 jours.

Cela permet de retrouver les modifications, action par action mais l'inconvénient est que cela crée des tonnes de fichiers, difficiles à organiser ; on finit par ne plus retrouver le fichier réel de comptes.

On va donc enlever ces paramètres par défaut, de sorte que le dossier « mes-comptes » ne contiendra qu'un seul fichier représentant tous les comptes.</note>

Au premier lancement de GnuCash, deux fenêtres apparaissent.

Appuyer sur Annuler pour paramétrer tout de suite GnuCash.

Un tutoriel est proposé mais il est en anglais.

Appuyer sur Fermer

<note tip>Ce petit assistant d'astuce est bien pratique. Décider s'il doit s'afficher à chaque démarrage de Gnucash. Ce choix peut être fait plus tard dans Édition → Préférences → Général</note>

La page principale de GnuCash apparaît.

Le paramétrage se fait à partir du menu Edition → Préférences de GnuCash,

La fenêtre de paramétrage de GnuCash s'ouvre, les paramétrages par défaut sont bons.

Nous allons supprimer l'enregistrement automatique et l’enregistrement de l'historique.

Dans l'onglet Général, remplacer les minutes et jours par le chiffre 0 (0 = jamais)

Nous sommes maintenant prêt pour profiter pleinement et facilement de GnuCash !

0.1. Utilisation

0.1.1. Création de comptes

La hiérarchie de comptes se subdivise ainsi :

Pour la première création de compte, on utilise l'assistant de création de compte, très commode.

On peut ainsi, une fois les comptes créés, accéder pleinement aux diverses options de GnuCash.

aller dans Fichier → Nouveau → Nouveau Fichier

L'assistant s'ouvre.

Voici comment créer les comptes, étape par étape.

0.1.1.1. Rajouter un compte

Pour, par exemple, rajouter un LEP (Livret épargne populaire) :

Sur la page d'accueil des comptes, sélectionner dans le menu de GunCash : Fichier, et suivre les indications ci-dessous.

Une nouvelle fenêtre apparaît, pour gérer le nouveau compte.

Avant de valider, on peut naviguer entre l'onglet général et Solde initial autant de fois que désiré pour vérifier les données écrites.

Le un nouveau compte apparait dans la page d'accueil des comptes et son montant s'est rajouté aux soldes initiaux comme ceci :

0.1.2. Le menu de compte

Tout les comptes offrent le même menu, juste au dessus des onglets de compte.

Pour bien en comprendre les fonctionnalités, nous allons ouvrir deux comptes.

un avantage de GnuCash est que chaque compte s'ouvre en Onglet, ce qui facilite le passage d'un compte à un autre.

Pour ouvrir un compte, Sélectionner le compte et Faire Ouvrir

Un nouvel onglet s'ouvre directement sur la feuille du compte sélectionné.

Revenir sur l'onglet Comptes, sans fermer le compte ouvert pour en ouvrir un autre (par exemple : LEP). On devrait obtenir ceci :

Faisons un enregistrement des comptes. Même si aucune opération n'est encore faite, cela permet d'éviter de devoir tout refaire en cas de mauvaise manipulation.

C'est à ce moment que l'on nomme le fichier.

Dans le menu de compte, Faire enregistrer.

La fenêtre réapparaît avec au centre une page blanche : GnuCash vient de valider la destination où enregistrer le fichier. Confirmer en cliquant sur Enregistrer.

Le dossier « mes-comptes » contient maintenant trois fichiers. Ces trois fichiers sont la sauvegarde générale du fichier-comptes. Ils n'on pas d'icône. C'est normal.

En outre, un menu de compte passif s'affiche en bas de la feuille.

En voici l'explication :

A son prochain lancement, GnuCash ouvrira automatiquement le Fichier comptes.

0.1.3. Gérer les comptes

<note important>Il faut absolument « Antidater » le solde initial de chaque compte.

Le plus simple est de dater le solde initial un jour avant toute première édition d'opération.

Pour cela :

  • ouvrir l'onglet CCP
  • un clic gauche sur la date et donner une date antérieure à la création (la date d'hier, ou mieux, au 1er janvier de l'année)

Pour tous les comptes il faut changer la date du solde initial avant de commencer la gestion de vos comptes.

Ce n'est à faire qu'une seule fois, car le logiciel a besoin d'avoir une cohérence entre la base du solde initial et le début des futures opérations.</note>

0.1.3.1. Éditer des opérations

L'édition d'opération est un jeu d'enfant. Éditons quatre opérations.

<note tip>A chaque modification, GnuCash vous ouvre une fenêtre d'alerte pour informer de l'enregistrement de la dernière modification.

Cela peut devenir agaçant à terme mais très utile pour les têtes en l'air. Cette fenêtre réapparaitra à chaque modification même minime.

On peut désactiver cette alerte via le menu Edition → Préférences.

Choisissons de ne plus nous poser la question.

</note>

Sélectionner la ligne vierge (clic gauche).

  • date : par défaut, le jour actuel.
  • Num : permet d'indiquer le numéro de chèque ou de virement effectué. Pas indispensable, l'opération sera alors prise en compte sans Num.
  • Description : objet du retrait ou dépôt sur le compte (exemples : pneu / paye / électricité / cigarettes).
  • Virement : ce nom est trompeur, cette rubrique permet en fait de classifier les dépenses par thème sur la page d'accueil des comptes.
    Ne jamais laisser cette rubrique vide. Un clic gauche dans cette rubrique ouvre une liste de catégories.

  • R : Rapprochement ; une opération rapprochée est une opération qui a été créditée ou débitée sur le compte en banque (voir le chapitre 7.3 qui suit pour de plus amples informations).
  • Dépôt : ce qui rentre en positif sur le compte, appelé aussi Crédit sur les relevés de comptes. ( + )
  • Retrait : ce qui sort en négatif sur le compte, appelé aussi Débit sur les relevés de comptes.( - )
  • Solde : c'est le nouveau montant restant sur le compte après imputation de/ou des opération(s).

La touche + valider permet d'enregistrer l'opération que l'on vien de faire, mais aussi d'ouvrir une nouvelle ligne vierge. Toujours faire +Valider après chaque opération.

Nous allons éditer 4 Opérations:

  1. un achat de pneus d'un montant de 500 eu,
  2. une facture d'électricité de 50 eu,
  3. un revenu (paye) de 1500 eu (qui arrivera le lendemain, soit le 25/05),
  4. un paquet de cigarettes à 5,50 eu.

En entrant ces opérations selon les explications, on devrait obtenir ceci :

0.1.3.2. Supprimer ou dupliquer des opérations

Sélectionner l'opération et choisir, dans le menu de compte, l'action :

0.1.3.3. Rapprocher des opérations

Une opération rapprochée est une opération qui a été créditée ou débitée sur mon compte en banque.

  • N = Non rapproché
  • P = Pré-visualiser ( pointé)
  • O = Oui rapproché

Pour le moment notre compte a un solde initial, des opérations mais rien n'est rapproché ce qui se confirme visuellement par la lettre N.

<note important>Il est impératif de rapprocher en premier lieu le solde initial, car GnuCash ne comprendra pas des opérations sur un compte sans solde initial.</note>

Pour rapprocher suivre le guide ci-dessous :

dans le menu du compte, un clic sur Rapprocher .

Une nouvelle fenêtre s'ouvre.

Sélectionner à partir de quelle date on veut faire le rapprochement.

<note important>seules les opérations qui débutent à la date sélectionnée seront rapprochées ! Il est fortement déconseillé de supprimer un rapprochement fait, considérer que le rapprochement est définitif !</note>

Sélectionner l'opération à rapprocher, à la bonne date

Faire de même pour les 3 autres opérations en respectant la chronologie des dates ; ici, elles ont la même date : on peut cocher les trois pour faire une validation groupée.

Pour la 4ème opération (paye CATIC), on voit que la date n'est pas encore d'actualité, le rapprochement est donc inutile.

On devrait obtenir ceci :

O confirme que le rapprochement a été validé.

0.1.3.4. Planifier

La planification permet d'éviter de retaper des opérations mensuelle-annuelle ou hebdomadaire.

Elle fait gagner un temps considérable dans la gestion des comptes.

Prenons l'exemple de la facture d'électricité. Elle est de 50 eu, l'opération est indiquée (voir exemple ci dessus) on va la planifier mensuellement.

Pour cela sélectionner l'opération (clic gauche sur « électricité ») puis un clic sur :

Une nouvelle fenêtre s'ouvre, choisir les réglages :

Nous venons de planifier une opération mensuelle .

Dans l'exemple, GnuCash éditera tous les 24 du mois l'opération électricité = retrait pour une somme de 50 eu automatiquement sur la feuille de compte. Il ne reste plus qu'à faire le rapprochement dés que la banque le prendra en compte.

<note tip>On peut vérifier ou modifier toutes les planifications en sélectionnant la ligne d'opération puis dans le menu de compte : Planifier → Avancé.</note>

0.1.4. Exporter ou importer des comptes sous GnuCash

0.1.4.1. Exporter

Exporter des comptes = envoyer des comptes

Pour exporter suivre les indications des flèches (clic gauche sur la rubrique) :

On vient de créer un Fichier-comptes exportable, il suffira d'indiquer à un autre logiciel de comptabilité d'importer ce fichier.

0.1.4.2. Importer

Importer des comptes = recevoir des comptes.

<note important>Bien être sûr de connaître le format du fichier à importer.</note>

Exemple : importer un fichier au format QIF fait sur Grisbi, un autre logiciel de comptabilité libre (ce qui suppose donc que les comptes ont été exportés au format QIF sur Grisbi).

Le fichier est importé. Les comptes Grisbi sont sous GnuCash

0.1.5. Conclusion

L'exploration de GnuCash est maintenant terminée. GnuCash permet aussi de gérer des comptes professionnels.

Il existe diverses options de confort, à découvrir :

  • Voir Edition → Feuille de Style
  • ou changer le mode d'affichage .
  • etc.

Bien-sûr, ne pas faire faites pas ce genre de test sur les vrais comptes. Finaliser les préférences avant de les appliquer au fichier de comptes réel.

0.2. Désinstallation

0.2.1. sous Ubuntu

Pour supprimer cette application, il suffit de supprimer son paquet. Selon la méthode choisie, la configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.

0.2.2. sous Windows

Voir aussi


Basé sur le tutoriel de Framasoft par Stéphanie Raya.


Navigation